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Document Overview
This document describes how to install and configure the various components for a Live system. In
particular, this version of the document applies to v8.0 of the ICMLive and SWMMLive products.
The reader should consult the relevant, component-specific, documentation for more detail on the
installation and configuration of each of these components.
The reader should consult the Tutorial documentation for guidance on creating and populating a
Master Database with the necessary modelling data to deploy onto their Live installation.
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System overview
A complete Live system consists of the following components:








ICMLive / SWMMLive Configuration Manager
ICMLive / SWMMLive Operator Client
Innovyze Live Server
Innovyze Workgroup Data Server
Innovyze Data Loader
Innovyze Server Configuration Manager
InfoWorks ICM Agent & Coordinator

ICMLive / SWMMLive Configuration Manager
These extensions of the InfoWorks ICM application enables the user to run and calibrate their
systems against external data (such as network telemetry, rain-gauge telemetry and rainfall radar
image files), create the ICMLive or SWMMLive specific objects which the Live system requires to
operate, and deploy their final system to the Innovyze Live Server.

ICMLive / SWMMLive Operator Client
These applications enable real-time monitoring of the Live system, giving the user an overview of the
current state of their network collection, detailed network pages of their simulation results (both
real-time and archived) and the ability to create ‘what-if’ manual simulations containing user edits.

Innovyze Live Server
This background process is responsible for all automatic processes within the Live system, such as
automatic simulation scheduling, alert generation and data-warehousing. It also communicates realtime system information to all connected Operator Clients.

Innovyze Workgroup Data Server
This background process manages all interaction with the Workgroup database (where all network
data, time series data, etc. are stored). ICMLive and SWMMLive do not support a Standalone
database. A Standard, Oracle or SQL Server database should be used.

Innovyze Data Loader
This background process is responsible for processing any external data feeds (e.g. radar files,
telemetry database values) and adding the data into the Live system independently of any
simulation scheduling. It is an optional component; simulations can be configured to process the
external data feeds on a Just-In-Time basis and in this case the Data Loader is not required.

Innovyze Server Configuration Manager
This application allows the system administrator to configure both the Innovyze Live Server and the
Innovyze Data Loader; e.g. which Master Database the application is pointing at, what licence the
Live Server is using, etc.
Note: this application is also responsible for Web Services configuration. This is not relevant for
ICMLive or SWMMLive at the time of writing.
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InfoWorks Agent & Coordinator
The Coordinator(s) and Agent(s) are responsible for actually running the simulations, both automatic
and manual, as required by the system. They also run a number of other jobs which may be
required by the Live system. These components can be shared across a Live system and a normal
ICM system.
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Installation
(Existing ICM/InfoNet users may have already installed some of these components)
The Innovyze Workgroup Data Server is installed from the file:
WorkgroupDataServer[x64|x86]_VersionNumber.msi
The ICMLive Configuration Manager and ICMLive Operator Client, SWMMLive Configuration
Manager and SWMMLive Operator Client and InfoWorksAgent & Coordinator are all installed from
the file:
InnovyzeWorkgroupClient[x64|x86][_MapControl]_VersionNumber.msi
The Innovyze Live Server and Innovyze Server Configuration Manager are installed from the file
(note this component is available for x64 systems only):
LiveServer_VersionNumber.msi
The Innovyze Data Loader is installed from the file (note this component is available for x64 systems
only):
DATALOADER_VersionNumber.msi
If a remote agent is required (i.e. simulations are to be run on a machine other than one that already
has an agent installed as part of ICM or ICMLive / SWMMLive Configuration Manager), this is
installed from the file:
InnovyzeRemoteAgentx64__VersionNumber.msi
It is possible to install all components on a single machine (provided the machine has an x64 OS,
because the Innovyze Live Server is only available as an x64 executable), or each component on a
separate machine or any combination, as necessary. Some example installations are described
below.

Licensing
Currently five types of licence are required to utilise the full functionality of ICMLive or SWMMLive:





ICMLive / SWMMLive Configuration Manager (which is an add-on to the standard ICM
licence)
ICMLive / SWMMLive Operator Client
Innovyze Live Server
Simulation Engine

Configuration
Certain specific configuration is necessary for the Live system to function correctly: this is
particularly relevant if ICMLive or SWMMLive is being installed ‘over’ an existing ICM system (as the
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ICM system may have been configured in a way that requires modification in the presence of
ICMLive or SWMMLive).
For more detailed information on the configuration of each separate component, please consult the
component-specific information.

Remote Results folder
(It is assumed the user already has at least a Master Database created in ICM, ICMLive Configuration
Manager or SWMMLive Configuration Manager which they intend for use in the Live system).
It is required that a ‘remote results root’ is used in the Live system, because in general simulations
within ICMLive and SWMMLive are intended to be shared between users and this is best achieved in
this way. Most ‘Live’ functionality will only be available if a Remote Results folder is being used.
The ‘remote results root’ can be set from within ICM or ICMLive / SWMMLive Configuration
Manager and is a Master Database-specific setting (File->Master database settings->Set remote
roots). The directory string should be meaningful for any other PCs on the network (e.g.
\\TheFileServer\RemoteResultsRoot, rather than D:\RemoteResultsRoot) and should be a real path,
not a mapped drive e.g. S:\RemoteResultsRoot.
Each relevant Windows user account should have read/write access to the designated ‘remote
results root’ directory. Relevant user accounts are the personal user accounts of all users of the
system, but also the user accounts under which the system processes are run (namely the Innovyze
Live Server and DataLoader processes).

InfoWorks ICM Agent
The Agent that the Innovyze Live Server connects to should be an Agent that is part of a ‘Coordinator
Workgroup’. This is achieved from the “Manage Simulation Agents” dialog from the Job Control
window in ICM, ICMLive / SWMMLive Configuration Manager, or ICMLive / SWMMLive Operator
Client, please consult Agent-specific documentation for complete instructions.
In brief, the Innovyze Live Server’s Agent should be of type ‘Workgroup’, and should either have the
option “Use this agent as the coordinator” set, or have the option “Use coordinator on (computer
name or IP address)” set and a valid machine name/IP address in that text-box. In the latter case, on
the specified machine there should be a Workgroup Agent installed running as Coordinator.
The InfoWorks ICM Agent should run under the local system account. Note that the Innovyze Live
Server will submit jobs to the Agent using the username of the account under which the Live Server
is running, provided the advanced option SimControl.RunAsLogonUser is set to true (this is the
default setting). If this setting is set to false then all connected Agents should run under a named
account as described below.

Innovyze Live Server
Configuration for the Innovyze Live Server is carried out through the Innovyze Server Configuration
Manager. The Innovyze Live Server requires one and only one Master Database to be specified
before it can be started. Therefore the Server can only be started once a suitable Master Database
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has been prepared (in particular, at least one ‘Manifest Deployment’ has been created and
configured, and most likely, deployed).
It is strongly recommended that only Master Databases of the “Workgroup” type are used in the Live
system.
(“Workgroup” Master Databases have been designed to work in a multi-user, multi-machine
environment and this is best suited to a Live system).
The Innovyze Live Server should be configured so that it:
a) points to the relevant Master Database,
b) has the necessary licence configuration.
Please see the Innovyze Live Server Administration document for more details on how to do this.
The Innovyze Live Server service uses the “Local System account” by default, but this must be
changed. This is done through the Services dialog (right-click on the service, select “Properties”) like
this:

Where the Windows user account “bob” should have appropriate permissions, in particular
read/write access to the “Remote results root” (The Local System account is not able to do access
the Remote results root).
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It should be noted that if the Live Server is re-installed, this particular setting is lost, and must
therefore be repeated.
Once the server configuration has been completed, the Innovyze Live Server Windows service should
be started using the Windows Services dialog.

Innovyze Data Loader
Configuration for the Innovyze Data Loader is carried out through the Innovyze Server Configuration
Manager.
Please see the Innovyze Data Loader Administration document for more details on how to do this.
The Innovyze Data Loader should run under a named account in the same way as the Live Server, so
that the named user has the appropriate permissions depending on the types of TSDB datasources
that are used e.g. access to SQL Server, or to file shares where telemetry is located.
Once the server configuration has been completed, the Innovyze Data Loader Windows service
should be started using the Windows Services dialog.

ICMLive and SWMMLive Operator Client
Server connectivity
Connectivity to/from the Server is configured from the menu option File->Server connection…, or
directly from the Server connection icon in the Overview toolbar. The name of the machine running
the Innovyze Live Server process should be entered here (e.g. for the machine called
“LiveServerPC”).

For further details, please consult the Innovyze Live Server Administration document.
When successful connection to the Innovyze Live Server has been made and a Manifest Deployment
has been selected, a number of useful messages from the Innovyze Live Server can be found in the
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Server Messages tab on the Overview Page of the ICMLive / SWMMLive Operator Client, such as
simulation scheduling, maintenance processing, etc.
Innovyze Live Server’s Agent to Operator Client connectivity
To be able to monitor in detail (and potentially administer, depending on account privileges)
automatic runs generated by the Innovyze Live Server, the Server Job Control window within the
ICMLive / SWMMLive Operator Client can be pointed at the Agent that the Server uses.
This is done by opening the Manage Simulation Agents dialog from the Server Job Control tab within
the ICMLive / SWMMLive Operator Client. For example below the Operator Client’s Server Job
Control Window has been pointed at the Innovyze Live Server Agent running the machine
LiveServerPC.
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Agent connectivity
To be able to monitor and administer manual runs generated from the ICMLive Operator Client, the
Job Control window within the ICMLive Operator Client can be pointed at the Agent that will run
manual runs.
This is done by opening the Manage Simulation Agents dialog from the Job Control tab within the
ICMLive Operator Client. For example, below the Operator Client has been pointed at the Agent
running on the same machine as the Operator Client itself (i.e. the Agent running on ‘localhost’). In
this particular case, because it is a connection to an Agent on the same machine, the recommended
“Pipe to local agent running on this computer” has been chosen).
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Example installations
Two contrasting example installations are considered: the first, a self-contained ‘complete-systemon-one-PC’, the second, an ‘enterprise’ installation where the various Live components are deployed
on separate boxes on the same network.
It is assumed either a network licence with the necessary licence options is available, or physical
dongles with the necessary licence options have been inserted into each machine, or some
combination thereof.

Single machine installation
1. Workgroup Data Server
1.1. Install the Workgroup Data Server.
2. Innovyze Workgroup Client
2.1. Install the Innovyze Workgroup Client.
2.2. Use the Licence Key Setup from the Innovyze Workgroup Client directory in the Start Menu
to configure the system licensing.
2.3. Start the ICMLive / SWMMLive Configuration Manager application and open the “Manage
Simulation Agents” window from the Job Control window. Make sure the “Connection to
local agent” is set to “Pipe to local agent running on this computer”.
2.4. Make sure the Agent is running as a Coordinator, and not Standalone (if not, click on Local
Agent in the list box, press the “Load” button, select the “Workgroup” radio button, and
press the “Save” button. The Agent should now be running as a Coordinator as required.
2.5. Set the “Log On” account for the Agent service to a suitably privileged user account (see
above for details).
2.6. At this point a Master Database for the Live system should be built (see the Tutorial
document for more guidance).
3. Remote Results Root
3.1. Create a Remote Results Root directory somewhere in the PC directory structure. The
Windows user account(s) that are used in the Live system must have access to this
directory.
3.2. In the ICMLive / SWMMLive Configuration Manager, set the Master Database Remote
Results root to point to the directory created above (File->Master database settings->Set
remote roots).
4. Innovyze Live Server and Data Loader
4.1. Install the Innovyze Live Server.
4.2. Install the Innovyze Data Loader.
4.3. Edit C:\ProgramData\Innovyze\LiveServerData\liveserver.cfg (as administrator), entering
(as a minimum) the Master Database name and necessary licensing information (if running
on Windows XP, the file is located in C:\Documents and Settings\All Users\Application
Data\Innovyze\LiveServerData).
4.4. If desired, set the “Log On” account for the Innovyze Live Server service to a suitably
privileged user account (the default “Local System account” should be sufficient, however).
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4.5. Start the Innovyze Live Server service from the Windows services page.
5. ICMLive / SWMMLive Operator Client
5.1. Install the ICMLive / SWMMLive Operator Client.
5.2. Start the Operator Client application, and open the “Manage Simulation Agents” window
from the Server Job Control window. Make sure the “Connection to local agent” is set to
“TCP/IP to local agent running on computer”, the text-box contains “localhost”, and the
“TCP/IP port” should be set to 40001 (unless this has been changed [press the Agent
options to clarify]).
5.3. Make sure the Agent is running as a Coordinator, and not Standalone (if not, click on Local
Agent in the list box, press the “Load” button, select the “Workgroup” radio button, and
press the “Save” button. The Agent should now be running as a Coordinator as required.
5.4. The Tutorial document should again be consulted for in-depth guidance on the use of the
Operator Client, but the overall state of the system can be assessed from the Server
Messages window.
5.5. Open the Master Database that has been prepared (File->Open new database).
5.6. Select the Manifest Deployment that has been deployed (File->Select manifest
deployment).
5.7. Open the Server Messages window (Window->Server Messages). This message log outlines
all the key behaviour of the Innovyze Live Server and therefore the system as a whole. A
message should be visible in this window indicating the Innovyze Live Server has started.

Multiple machine installation
In this scenario, the various components of the system are distributed across several machines
within the same network (although some components are installed on the same machine for
reasons of efficiency).
So consider three separate PCs (in fact, PC_Servers may actually be connected to several more
machines with Agents installed on them as a ‘simulation farm’, but that is outside the scope of this
document – please consult Agent-specific documentation for guidance on this topic).


PC_Servers
Runs: Workgroup Data Server, Innovyze Live Server, Coordinator, (Innovyze Data Loader)
Contains: Remote Results Root directory, Radar raw data directory



PC_ConfigMan
Runs: ICML Configuration Manager



PC_OpClient
Runs: ICMLive / SWMMLive Operator Client

In this example, PC_ConfigMan and PC_OpClient will connect to the Coordinator on PC_Server and
so submit their simulation jobs to that machine. Therefore manual and automatic runs will be sent
to the same queue.
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If it is preferred that off-line/manual simulations are kept separate from automatic ones, one option
is to run Coordinators on PC_ConfigMan and PC_OpClient so that simulations from those two
applications are run on their local PCs. In this case the Coordinators on PC_ConfigMan and
PC_OpClient should be configured as in the single machine installation example above.
1. Workgroup Data Server
1.1. Install the Workgroup Data Installer on PC_Servers.
2. Innovyze Workgroup Client
2.1. Install the Innovyze Workgroup Client on PC_ConfigMan.
2.2. Use the Licence Key Setup from the Innovyze Workgroup Client directory in the Start Menu
to configure the system licensing.
2.3. Start the ICMLive / SWMMLive Configuration Manager application and open the “Manage
Simulation Agents” window from the Job Control window. Make sure the Local Agent is a
Workgroup agent, and not Standalone (if not, click on Local Agent in the list box, press the
“Load” button, select the “Workgroup” radio button. Also select the “Use coordinator on”
radio button and enter PC_Servers in the text box. Now press the “Save” button).
2.4. At this point a Master Database for the Live system should be built (see the Tutorial
document for more guidance).
3. Remote Results Root
3.1. Create a Remote Results Root directory in the directory structure of PC_Servers. The
Windows user account(s) that are used in the ICMLive system must have access to this
directory.
3.2. In the ICMLive / SWMMLive Configuration Manager, set the Master Database Remote
Results root to point to the directory created above (File->Master database settings->Set
remote roots).
4. Innovyze Remote Agent
4.1. Install the Innovyze Remote Agent on PC_Servers.
4.2. Open the Agent Manager application (Start->All Programs->Innovyze Remote Agent x64
[Version number]).
4.3. Make sure the Agent Configuration is “Workgroup”.
4.4. Make sure the option “Use this agent as the coordinator” is selected.
4.5. Make sure the “Act as local agent” option is ticked.
4.6. Click on the Start button.
4.7. The Agent Manager application may now be closed.
5. Innovyze Live Server
5.1. Install the Innovyze Live Server on PC_Servers.
5.2. Install the Innovyze Data Loader.
5.3. Edit C:\ProgramData\Innovyze\LiveServerData\liveserver.cfg (as administrator), entering
(as a minimum) the Master Database name and necessary licensing information (if running
on Windows XP, the file is located in C:\Documents and Settings\All Users\Application
Data\Innovyze\LiveServerData).
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5.4. If desired, set the “Log On” account for the Innovyze Live Server service to a suitably
privileged user account (the default “Local System account” should be sufficient, however).
5.5. Start the Innovyze Live Server service from the Windows service page.
6. ICMLive / SWMMLive Operator Client
6.1. Install the ICMLive / SWMMLive Operator Client on PC_OpClient.
6.2. Start the Operator Client application.
6.3. Open the Job Control window, and open the “Manage Simulation Agents” window by
clicking on the relevant button in the toolbar. Make sure the Local Agent is a Workgroup
agent, and not Standalone (if not, click on Local Agent in the list box, press the “Load”
button, select the “Workgroup” radio button. Also select the “Use coordinator on” radio
button and enter PC_Servers in the text box. Now press the “Save” button.
6.4. Repeat the previous item for the Server Job Control window.
6.5. The Tutorial document should again be consulted for in-depth guidance on the use of the
Operator Client, however to quickly check on the state of the system, open the Operator
Client application.
6.6. Open the Master Database that has been prepared (File->Open new database).
6.7. Select the Manifest Deployment that has been deployed (File->Select manifest
deployment).
6.8. Open the Server Messages window (Window->Server Messages). This message log outlines
all the key behaviour of the Innovyze Live Server and therefore the system as a whole. A
message should be visible in this window indicating the Innovyze Live Server has started.
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Troubleshooting
Here is a list of common issues caused by incorrect system configuration:
1. The Innovyze Live Server service doesn’t start and a dialog like this is displayed:

All possible Innovyze Live Server start-up errors and recommended remedies are covered in the
Innovyze Live Server Administration Guide. Make a note of the server-specific error code given in
the error dialog (e.g. in the example above, it is 102) and look it up in the companion document.
2. The Innovyze Live Server isn’t able to dispatch automatic simulations
In the Server Messages window of the Operator Client, I see a message like this:
Unable to dispatch simulation immediately, will retry later:
manifest_id=202, sim_id=604, alert_id=605, type=full, origin=2013Jan-14 11:15:00, (A Simulation Agent client connection is not
available (The Simulation Agent Coordinator is not available))
Solution:
Make sure the Agent that the Innovyze Live Server is connected to is running as Coordinator, or is at
least connected to a Coordinator on another machine.
3. The Innovyze Live Server isn’t able to dispatch automatic simulations #2
In the Server Messages window of the Operator Client, I see a message like this:
Failed to dispatch simulation: manifest_id=27, sim_id=0, type=full,
origin=2013-Jan-14 13:30:00 (The remote results root is invalid
(<empty>))
Solution:
Open the Master Database in ICM or ICMLive / SWMMLive Configuration Manager and assign a
‘results remote root’ as described here: Remote Results folder

4. Automatic simulations and alert jobs are not uploaded to the server
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In the Server Job Control window the Simulation and Alert Generation jobs fail, both with Status:
Failed – Unable to upload states/results to server
In the Server Messages window of the Operator Client, I see a message like this:
Simulation failed: manifest_id=5, sim_id=6294, job=SA_A5D2A7A8-09A44E87-A9FA-EF14B4A5002E_23_6294_InnovyzeLiveServer_20131108_171602
(Unable to upload states/results to server)
Followed by
Alert generation failed: manifest_id=5, alert_id=6295,
job=SA_A5D2A7A8-09A4-4E87-A9FAEF14B4A5002E_185_6295_InnovyzeLiveServer_20131108_171602 (Unable to
upload states/results to server)
Solution:
Check that the Infoworks ICM Agent Service is running under a Windows user account that has
read/write privileges to the ‘remote results root’.
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